Kawasaki KRX Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter #1
Seeing if anyone is/or has had this issue ..

Machine is idling at 1800 RPM, therefore hard to switch thru high/low/revers while running. When turn engine off, easy to switch and like normal.

Here is a site describing and looks like it's case #2


Any feedback to solving much appreciated.
Thanks
 

·
Registered
Joined
·
25 Posts
Im getting the impression that kawi is replacing parts and dealerships are doing the work, as opposed to the typical, "they just do that, it's normal" answer.
That's encouraging.
 

·
Registered
Joined
·
295 Posts
Discussion Starter #6
I didn't get fixed..
Took to dealer, being I had ECU flash done, they immediately determined they thought was the flash.

I have called programmer, they have said wasn't, and couldn't but willing to reflash.

Honestly here is what I think if not ECU, as I am going to have it reflashed.

Thinking got bad run on gas causing
Fouled plug, or clogged injector.

Also could be an air leak.

Either way I'm going to try the flash first see if that comes back and everything is okay. I have 200 miles on it with flash done and it was fine. And the another 150 here and not good.

It is idling at 1800 rpm, and of course clutch engaged and pulling away, so no gear can be changed.

What are u seeing?
 

·
Registered
Joined
·
173 Posts
I didn't get fixed..
Took to dealer, being I had ECU flash done, they immediately determined they thought was the flash.

I have called programmer, they have said wasn't, and couldn't but willing to reflash.

Honestly here is what I think if not ECU, as I am going to have it reflashed.

Thinking got bad run on gas causing
Fouled plug, or clogged injector.

Also could be an air leak.

Either way I'm going to try the flash first see if that comes back and everything is okay. I have 200 miles on it with flash done and it was fine. And the another 150 here and not good.

It is idling at 1800 rpm, and of course clutch engaged and pulling away, so no gear can be changed.

What are u seeing?
Mike have you checked to see if its something simple like maybe a wire or something is on the accelerator cable? here's what I found to adjust it:
551

Torque· Throttle Cable Adjusting Nut : 4.4 N·m (0.45
kgf·m, 39 in·lb)
• Slide back the dust cover to the original position.
  • Adjust the throttle cable adjusting nuts of the throttle pedal side so that the throttle cable has no slack keeping the throttle pulley completely closed.
  • Adjust the throttle cable adjusting nuts of the throttle pedal side so that throttle pulley becomes full open at throttle pedal full stroke position.
  • Loosen the throttle cable adjusting nut [A] by 2 pitches so that the throttle cable has a slight slack.
    • Tighten:
    Torque -Throttle Cable Adjusting Nut : 4.4 N·m (0.45 kgf·m, 39 in·lb)

IS05057BS1 S
B
IS05058BS2 S
552
1595792833476.png
1595792833598.png
 

·
Registered
Joined
·
6 Posts
Mike, mine did it right after the reflash also. I called the guy who re-flashed it. He said it needs to learn the idle again. That I need to just Drive it some. I drove it today and it started acting normal. I started it back up later in the day after it has cooled off and it was idling high again but eventually came down. Hopefully it is still learning the idle? I still think there might be something going on with my throttle position sensor because it idle high once before the reflash and was hard to shift.
 

·
Registered
Joined
·
295 Posts
Discussion Starter #9
Mike, mine did it right after the reflash also. I called the guy who re-flashed it. He said it needs to learn the idle again. That I need to just Drive it some. I drove it today and it started acting normal. I started it back up later in the day after it has cooled off and it was idling high again but eventually came down. Hopefully it is still learning the idle? I still think there might be something going on with my throttle position sensor because it idle high once before the reflash and was hard to shift.
Who did your reflash?
 

·
Registered
Joined
·
6 Posts
I would try to get your money back from Alba and get a V force John reflash. Supposed to be a lot better than Alba. Did the dealership try to charge you when they found out it was re-flashed?
 

·
Registered
Joined
·
173 Posts
I would try to get your money back from Alba and get a V force John reflash. Supposed to be a lot better than Alba. Did the dealership try to charge you when they found out it was re-flashed?
yea.. sounds like a bit more R&D could have gone into that flash.. Does Alba own a Krx?
 

·
Registered
Joined
·
295 Posts
Discussion Starter #14
I would try to get your money back from Alba and get a V force John reflash. Supposed to be a lot better than Alba. Did the dealership try to charge you when they found out it was re-flashed?
Dealership no charge, as they owe me favors

Gas cables were checked etc..
Looked for air leaks.

Alba is going to retune (no charge)

Yes they have a KRX on Dyno with Trinity full exhaust like I have.
 

·
Registered
2020 white KRX 1000
Joined
·
78 Posts
Mine just now started idling high this morning. It also has Alba tune, but I have made many riding trips since tune without incident until today. Not sure what is going on. Any update?
 

·
Registered
Joined
·
295 Posts
Discussion Starter #17
Mine just now started idling high this morning. It also has Alba tune, but I have made many riding trips since tune without incident until today. Not sure what is going on. Any update?
Dan
I have update, mines now fixed, u can PM me and call me alot to explain
 

·
Registered
Joined
·
295 Posts
Discussion Starter #19
I'd be curious to hear what went on.
Will try to sum it up as short as I can.

After getting the tune done from Alba racing and adding a full Trinity exhaust with header and all. Seen good things out of the tune and performance upgrades.

Took it one trip and maybe even more to Hatfield and McCoys everything worked great. On the second trip to Hatfield and McCoys probably 250 mi in since the tune. I noticed a lot of backfiring. Knowing me I thought I just got a bad run on gas. Got home put in new gas and fuel injector cleaners. Ran it for sometime to clean the system thinking that was the issue. Nothing

Somewhere in here I then noticed that I was having a problem shifting from high to low to reverse. That's when I noticed I had an RPM issue. Instead of running 1200 and 1250 it was now running anywhere from 1800 to 2100.
No good.

Speaking to several people they told me to check the cable coming from the pedal which I did, wasn't the issue

I was also told to check for air leaks from the air filter back.
Nothing

I was told to pull plugs and look for rich or running lean. I did everything checked out okay.

I sent it to my local service guy Kawasaki dealer. They immediately told me it was from the tune.

Called Alba racing. I was told to ship it back and they would take a look. After receiving they called me, told me they had done many many of those and they didn't see where it was issue. Finally they said they would go back to stock on the RPM and that should handle it and fix it.

It was mailed back to me, I added it back in and saw no difference.

Getting frustrated at this point all of a sudden a service light came on inside my unit and the four drive and differential lock did not work on my next outing from Hatfield and McCoys.

I took it to the dealership once again to also have the new steering knuckles and a arms put on from recall. At this time I wanted them to look at the service light as well which ended up being an actuator. and also at this point is becoming a major issue for Kawasaki and there are many recalls.


dealership once again told me that the tune was my issue for the high RPMs and backfiring. They run an update on my ECU which ended up flashing it back to stock and it solved my problems.
1200 RPMs no back firing.

But I do have an issue because I do have a full muffler which In time we'll be running either rich or lean and I'm not getting the performance from the Ecu.

Either way I hope this helps to sum up the story The album racing flash is a joke
 
1 - 20 of 23 Posts
Top