Kawasaki KRX Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Anyone one else having issues with bluetooth cutting in and out .. After about 10 minutes with phone in dry cubby. On dash above deck. Music Starts cutting in and out like its out of range . Dealer replaced sub and amp box now its worse .. Gonna take it back and they are gonna change the head . it wirks fine if i move it away from the deck. In my pocket .. Thanks
 

·
Registered
Joined
·
178 Posts
From the reviews on the forum about the Hifonics system, there are a bunch of issues with them. Not sure if that is normal or not, but hopefully it can be fixed. Good luck
 

·
Registered
Joined
·
28 Posts
Mine was trying to switch between inputs and Kawasaki replaced the head for me under warranty. No issues on the new one... yet.
 

·
Registered
2021 KRX SE
Joined
·
169 Posts
Mine would play about 10 minutes then shut off, kawi replaced head unit first an didn't fix it. Then replaced subwoofer/amp an I haven't had any issues since. Kawi Said they had a bad run of amps and they were over heating an shutting down. But sounds like your issue is a little different than what I had going on.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #5 ·
Thanks guys. Sounds like maybe when head is replaced .. All will be good .. Fingers crossed
 

·
Super Moderator
2020 Green KRX
Joined
·
1,145 Posts
Question for you guys is all of this equipment water proof? Radio speakers subs amp?
 

·
Registered
Joined
·
7 Posts
The audio stopped working on ours. It acts like it’s playing but we can’t get any sound. Anyone else run into this?
 

·
Registered
2021 KRX SE
Joined
·
169 Posts
The audio stopped working on ours. It acts like it’s playing but we can’t get any sound. Anyone else run into this?
Does it do it on all channels, FM Radio, Bluetooth etc? Or don't have any sounds at all? An does it quit working after a while or won't work at all?
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #12 ·
If its under warranty my dealer has no issues replacing it . so yours shouldnt either
 

·
Registered
2021 KRX SE
Joined
·
169 Posts
Moe is right. They replaced head unit an amp/subwoofer on mine no problems. Took a while to get the Parts tho they was back ordered. But mine has worked flawless since.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #14 ·
Mine still works . they have my new head unit . i just got to get around to gettin out there to get it. . installed
 

·
Registered
Joined
·
7 Posts
Does it do it on all channels, FM Radio, Bluetooth etc? Or don't have any sounds at all? An does it quit working after a while or won't work at all?
No sound on any source. We've tried FM, Bluetooth and USB. It worked fine last week but could't get it to work at all on Saturday.
 

·
Registered
Joined
·
7 Posts
I wonder if there is a main fuse for the amp
The instructions show two inline fuses behind the dash. 1 for for +12v Constant and 1 for +12V Accessory. I was able to get to the accessory fuse and it was fine, but to get to the constant I'll have to take the dash apart.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #18 ·
Or maybe the plug .at bottom front left corner of the box came loose .
 

·
Registered
2021 KRX SE
Joined
·
169 Posts
No sound on any source. We've tried FM, Bluetooth and USB. It worked fine last week but could't get it to work at all on Saturday.
Oh ok. Well I hope u get it resolved an it's a simple fix like a fuse. But I do know my dealer said kawi/hifonics had a run of bad amps, thats what my issue wound up being. I lost sound intermittently because the amp was over heating an shutting down, but sounds like your issue is different.
 
1 - 20 of 24 Posts
Top