Kawasaki KRX Forum banner
1 - 9 of 9 Posts

·
Banned
Joined
·
503 Posts
Anyone experienced hard start after the machine is off for couple of hours? I have to hit the gas pedal a couple of times and it starts, turn off and start again is smooth.
Ok.. so from what you’ve described the first things I would do are... Replace the plugs.. drain tank and try new fresh gas make sure my air filter is clean. It’s an engine...it needs spark, fuel and air. Those are the 3 simplest things to address... start with them and go from there. It could be a number of things... it’s hard to diagnose off internet descriptions.
 

·
Registered
2021 Blue KRX
Joined
·
466 Posts
I’m also having an occasional hard start. If I’ve been riding and turn it off for 15ish or more minutes, it can be hard to start, like a carb that needs adjustment. Gas is non ethanol and always fresh. Vent mod has been done also. It doesn’t do this every time but it did it twice yesterday. The temp came down from operating to 140 on one of the two times. I gave it a bit of throttle during one failed attempt with no change. It finally started after 4-5 attempts.
 
  • Like
Reactions: Tyekay2390

·
Registered
Joined
·
26 Posts
I’m also having an occasional hard start. If I’ve been riding and turn it off for 15ish or more minutes, it can be hard to start, like a carb that needs adjustment. Gas is non ethanol and always fresh. Vent mod has been done also. It doesn’t do this every time but it did it twice yesterday. The temp came down from operating to 140 on one of the two times. I gave it a bit of throttle during one failed attempt with no change. It finally started after 4-5 attempts.
mine does this as well has 50 miles on it, drive it for an hour or so, then go to start 4-5 hours later it just cranks and dosent start until i cycle the key 2 or 3 times then starts right up
 

·
Registered
2021 Blue KRX
Joined
·
466 Posts
Mine did it again last weekend. I have it a little throttle while turning it over and it popped off.
 
1 - 9 of 9 Posts
Top