Kawasaki KRX Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
245 Posts
Discussion Starter · #1 ·
The fan on my 2020 died Saturday at 1250 miles. I thought it was a bearing but there's no play in the shaft, so I'm thinking a brush or something else came apart inside the motor. I got it running again but it's tripping the breaker and throwing a CEL for code 56 after a few minutes. I think it's been submerged once, I avoid mud and water when possible. I talked to one dealer today and they cant look at it until July 9th. The fans are in stock at the warehouse but they wont preorder the parts. The other dealer isn't open Mondays but I'll call them tomorrow. I'll add a pusher in front of the radiator if I cant get it replaced before the fourth.
 

·
Registered
Joined
·
100 Posts
Try to spin the fan blade by hand and see if it "feels" rough or catchs at all. From the video is definitely sounds weird.

Sent from my SAMSUNG-SM-G930A using Tapatalk
 

·
Super Moderator
2020 Green KRX
Joined
·
1,145 Posts
The fan on my 2020 died Saturday at 1250 miles. I thought it was a bearing but there's no play in the shaft, so I'm thinking a brush or something else came apart inside the motor. I got it running again but it's tripping the breaker and throwing a CEL for code 56 after a few minutes. I think it's been submerged once, I avoid mud and water when possible. I talked to one dealer today and they cant look at it until July 9th. The fans are in stock at the warehouse but they wont preorder the parts. The other dealer isn't open Mondays but I'll call them tomorrow. I'll add a pusher in front of the radiator if I cant get it replaced before the fourth.
Order that baby and install it! Shouldn’t be too bad of a fix.
 

·
Registered
Joined
·
77 Posts
sounds like the fan blades r hitting something like a plastic wire tie. Doesnt really sound like bearings. Just saying
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #5 ·
Try to spin the fan blade by hand and see if it "feels" rough or catchs at all. From the video is definitely sounds weird.

Sent from my SAMSUNG-SM-G930A using Tapatalk
It wouldn't spin at all before I got it turning by hand. After I got it moving I dumped a little 3in1 oil down the vent tube and it gained a few hundred RPM and would stay running a few minutes before tripping the breaker and setting the CEL. It was working normal for 1.5 days before this.

Order that baby and install it! Shouldn’t be too bad of a fix.
That was the plan until I saw the price. Best I saw was $320. For that price I'll use the warranty. It's also not as easy to get at as you would think. It may come out if you pull the right shock. If not it's going to take pulling a bunch of plastic and maybe the radiator.


sounds like the fan blades r hitting something like a plastic wire tie. Doesnt really sound like bearings. Just saying
I was hoping that was the issue but I don't get that lucky. It's in the fan motor. Tapping the motor will get the sound to change.
 

·
Registered
Joined
·
100 Posts
I'm sure at some point , someone will swap out the original for a Flex a Lite fan or something similar that will last. Might be able to to get one that will pull more cfm than the stock one. Opportunity for the aftermarket!

Sent from my SAMSUNG-SM-G930A using Tapatalk
 

·
Super Moderator
2020 Green KRX
Joined
·
1,145 Posts
It wouldn't spin at all before I got it turning by hand. After I got it moving I dumped a little 3in1 oil down the vent tube and it gained a few hundred RPM and would stay running a few minutes before tripping the breaker and setting the CEL. It was working normal for 1.5 days before this.


That was the plan until I saw the price. Best I saw was $320. For that price I'll use the warranty. It's also not as easy to get at as you would think. It may come out if you pull the right shock. If not it's going to take pulling a bunch of plastic and maybe the radiator.




I was hoping that was the issue but I don't get that lucky. It's in the fan motor. Tapping the motor will get the sound to change.
I’ve had good luck with mishimoto fans. I used them in my race car way back in the day. Might be a good alternative.
 

·
Premium Member
2020 KRX
Joined
·
1,120 Posts
There’s a couple videos over on Facebook regarding this issue. The magnets come unglued. You can either replace the fan with an aftermarket one, or pull the fan apart and use JB weld on the magnets.
 

·
Registered
Joined
·
2 Posts
My original fan died so I replaced it with a $70 Spal fan from Auto Zone. Same size but it does have a higher CFM. Now my fan works fine but I've had periodic issues where the fan stops working and I hear a clicking noise from the relay in the fuse box. I replaced the relay once too but it's still doing it. It might be fine for a few days and then starts acting up several times in one day. I can't figure it out yet but it's very frustrating.
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #13 ·
My original fan died so I replaced it with a $70 Spal fan from Auto Zone. Same size but it does have a higher CFM. Now my fan works fine but I've had periodic issues where the fan stops working and I hear a clicking noise from the relay in the fuse box. I replaced the relay once too but it's still doing it. It might be fine for a few days and then starts acting up several times in one day. I can't figure it out yet but it's very frustrating.
Thats what mine will do now if the fan locks up. There is a circuit breaker in there for the fan. Fan may be sticking or you are real close to the amp draw of that breaker.

Mine is going to the dealer to be warrantied on the 9th. I'm getting ready to go throw a pusher fan in front of the radiator until it goes in. A Suzuki Samurai coil plug is the same plug used on the oem fan if anyone ever needs replace it.
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #14 ·
Update. I dropped off the machine the end of last week Kawi approved the work and parts were ordered Monday. Kawi is requiring the relay and circuit breaker also be replaced to do high amp draw from the old fan stressing them. Everything but the relay was in stock so they are waiting on that. I'm going to give them a week before I start bitching to Kawi customer service about not have my machine over a relay that is working fine.
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #15 ·
Well, customer service is worthless. All it's really got me was an ETA on the relay. We ae now talking end of Sept for part that is working fine and can be picked up from most any parts store. I'll be letting them know today I will picking up my machine next week repaired or not.
 

·
Premium Member
2020 KRX
Joined
·
1,120 Posts
Well, customer service is worthless. All it's really got me was an ETA on the relay. We ae now talking end of Sept for part that is working fine and can be picked up from most any parts store. I'll be letting them know today I will picking up my machine next week repaired or not.
Get in contact with these guys. They make a digital fan conversion for the fans. You ship them off your fan assembly, and they rebuild it with theirs. It’s an electronic “step” fan, where it ramps up to speed, rather then full on/off. Much better voltage draw, especially at start-up. Steel Racing

I got in contact with them after seeing they make a complete drop in kit for can-spam. I inquired about one for the KRX, and as of now, they don’t have one. But they let me know they were going to start retrofitting for other rides (which they have) and I could send it in.

Great group of guys, and if and when my fan craps out, it’ll be off to them.
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #18 ·
Very nice option. I probably won't have the time to use them at this point but may send the old one to do the conversion on.
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #20 · (Edited)
Won't any automotive relay work? Not sure why it has to be a Kawi relay
Yes. It's a Denso relay so it's just a matter of finding another application that uses it. The breaker is a Mini ATC 15 amp breaker, nothing special. It has to be a Kawi relay because Kawi dealer and warranty, no actual reason.

I got them to get approval from Kawi today repair it with just the fan. Should have it back next week. It took 5 hours on the phone with customer care and the dealer just to get the two right people to talk to each other at Kawi and the dealer and get it approved in less then an hour.
 
1 - 20 of 20 Posts
Top