Kawasaki KRX Forum banner
1 - 20 of 22 Posts

·
Registered
2021 KRX Blue
Joined
·
898 Posts
Dewalt 20 volt for me I think it’s a 12” bar. With a sharp chain it handle 90% of what’s on trails. Won’t do the big stuff but it’s small and light. I also have the air compressor and the spotlight and the $270 impact, and the hedge trimmers great for briars. They all share batteries. On the X2 the chainsaw and stuff is in the bed. On the KRX it’s in the passenger floorboard.
2448
 

·
Registered
2021 KRX Blue
Joined
·
898 Posts
Holy shit!
I thought I had a story but not even going to bring it up now. Well... Mine is just a basic creek bank crossing that didn’t work.
 

·
Registered
Joined
·
569 Posts
I haven't done it yet but I'm thinking a mount across the front of the bed up on the cover would work well. With my seats folding forward it will go behind them but I like that space for other stuff. The hump in front of the bed is a nice high and dry wasted space right now.
 

·
Registered
Joined
·
42 Posts
Do any of you all carry a chainsaw with you? If so, what saw do you use and how do you carry it or mount it?

I just bought this one to carry on my trail rides

View attachment 2445
I carry a gas one starting in the spring. always have. Can't think of how marry times iv'e cleared the trail . i used to and still do sometimes, drive our old fj40 land cruiser, and come across a tree that has been barely cut for a small utv. Please clear the whole road .
 

·
Super Moderator
2020 Kawasaki KRX
Joined
·
2,067 Posts
I carry a gas one starting in the spring. always have. Can't think of how marry times iv'e cleared the trail . i used to and still do sometimes, drive our old fj40 land cruiser, and come across a tree that has been barely cut for a small utv. Please clear the whole road .
I couldn't agree more. I've seen that before and it makes no sense. If you have to cut it anyway, do it so it helps everyone.
 

·
Registered
2021 KRX Blue
Joined
·
898 Posts
My battery DeWalt saw steady leaks bar oil in the case I keep it in. Not a lot but always there. There’s no way I’d mount it exposed where it would do the same. Maybe this is just a problem with this saw.
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top